Adding a custom logo

To add a custom logo to your orchard website follow these steps:

    1. Place the logo file on your server (for example in the theme's folder /content/images)
    2. Edit theme file site.css
    3. Add to the bottom
#Logo a {
background:url(../content/images/YOURIMAGE) no-repeat;
display:inline-block;
font-size:0;
height: IMAGEHEIGHTpx;
width: IMAGEWIDTHpx; }
Have more questions? Submit a request

Comments

  • Avatar
    Bill Delaney

    I am using Kraft theme with Orchard 1.3

    Following these instructions because I want my logo to appear at top of home page with the Sitename.

    Inserted the code above into site.uncompressed.css and I did change the default values to be valid.

    Saved file (working in WebMatrix) and refreshed the local running site. No discernible change in home page.

    Is there a procedure I should follow to generate site.css from site.uncompressed.css?

  • Avatar
    Beatriz Oliveira

    Hi Bill, file site.uncompressed.css is meant to be used only as a reference if uncompressed code is necessary. If you want to use this code, you'll have to copy its content to site.css (this is the file used by Orchard).

  • Avatar
    Juan Felipe Gutiérrez Díaz

    Hi,

    I am using INVENT theme with Orchard v.1.3.10.0 and I adds the code to the bottom of site.css file but the logo not what show, the next is the code

    #Logo a {     background: url(../Content/Images/logo_clixone2.png) no-repeat;     display: inline-block;     font-size: 0;     height: 48 px;     width: 48 px; }

    Best regards.

     

     

  • Avatar
    Beatriz Oliveira

    Juan, can you provide a link to your website, so that we can debug directly?

  • Avatar
    mx

    Hi I have the metro theme and I have the same problem, I am running this on my desktop.

     

    #Logo a {     background: url(../Content/Images/mx_small.png)

    no-repeat;     display: inline-block;     font-size: 0;     height: 50 px;     width: 80 px; }

  • Avatar
    David Marlow Design

    Hi I'm having no luck getting a logo to appear on my Orchard website.

    #Logo a {
    background:url(../content/images/OCHT_logo.gif) no-repeat;
    display:inline-block;
    font-size:0;
    height: 80 px;
    width: 304 px; }

  • Avatar
    Beatriz Oliveira

    Please try removing space in height and width, like this:

    height: 80px;
    width: 304px;

  • Avatar
    David Marlow Design

    Thanks Beatriz. All sorted now.

  • Avatar
    Ozan Pakyuz

    Hmmm, have just applied a new Orchard theme and this is proving to be an issue for me, this is what I have:

    #Logo a {background:url(../content/images/OPSL_Logo.jpg) no-repeat;display:inline-block;font-size:0;height: 99px;width: 236px;}

    However no logo is displayed and trying to access the logo location directly resilts in a 404 error but the logo is definately in the correct place

    /Themes/THEMENAME/img/OPSL_Logo.jpg

    any advice?

  • Avatar
    Ozan Pakyuz

    OK ignore my previous comment I cannot read ;-)

  • Avatar
    Dan Holme

    I added the following style to the css:

    #Logo a { background:url("../Media/Default/images/IntelliemLogo.png") no-repeat; display:inline-block; font-size:0; height: 84px; width: 300px; }

    On my test site ( http://intelliem.azurewebsites.net), the AREA for the logo appears, but the logo does not, itself, appear, even though the URL is correct:

    http://intelliem.azurewebsites.net/Media/Default/images/IntelliemLogo.png

    How can I fix this?

     

  • Avatar
    Beatriz Oliveira

    Hi Dan, we just accessed your website and the logo is looking fine :)

    Maybe it's a cache issue? Please check, since all seems to be ok.

  • Avatar
    Dan Holme

    Sorry I forgot I had posted this issue here.  I found the problem: it was solely that my media was in "/Media/Default/images/IntelliemLogo.png" not "../Media/Default/images/IntelliemLogo.png"  :-)  Problem solved :-)

  • Avatar
    Raha Amirchermahini

    Hi there 

    I installed orchard on my windows localhost iis just to try it

    in the installation I entered "mysitename" as my site name and then enter the admin name and password to complate installation

    now i installed a metro them on my orchard but the name "mysitename" is known as my site logo

    how can I remove this name as my site logo and then add my personal logo to this site ?

    please help me

    thanks you all

    Sincerly :

    Raha

  • Avatar
    Beatriz Oliveira

    Hi Raha, please read the above article, it explains how to add the logo in 2 simple steps.

    Cheers!

  • Avatar
    Raha Amirchermahini

    HI 

    Dear Beatriz

    forgive me if my question is not related to this post

    but I cant open and edit Orchard theme . after I installed Orchard.metro 3.0.0. I cant to edit site.css file to change my logo

    now my logo is my site name in top of header placed as logo

    Im not be able open site.css in visual studio to edit and change my logo.

    how can I open and edit Orchard  theme file and then save them In there own place with the default name ?

    please help me

    forgive me for my bad english 

    Sincerly

    Raha

  • Avatar
    Pedro Monte

    Hi Raha, Can you tell us why can´t you edit the site.css in Visual Studio?

    Did you try to edit the file with other editor?

    To keep track of your issues and get full support, you can open a ticket here http://support.bind.pt/anonymous_requests/new

     

    Thank you

  • Avatar
    Raha Amirchermahini

    Hello Dear Pedro

    first of all forgive me for bad english

    I install orchard on iis in windows 8.1 

    and then install orchard.metrotheme 3.0.0. on the orchard

    now I cant open metro them by visual studio as a project 

    but i able to open it's file one-by-one with notepad but there is great problem to edit them 

    when I change some cod and many line of this theme and want to save the file it doent permission me to save edited file originally

    then I must save file in other place outside the inetpub/wwwroot and then replace this edited file with orginal file .

    this is my two question 

    1-how can I open installed orchard them in visual studio as a project ?

    2-how can I save edited files if orginal place in the inetpub\wwwroot ?

    I will thanks if any body help me to resolve these two problem 

    thanks agian Pedro and Beatriz

    Sincerly

    Raha

  • Avatar
    Pedro Monte

    Editing files in inetpub will give to that result by not letting saving the file, I think is the permissions or if the file is in use by the IIS.

    We don't  use Visual Studio to edit these files or create the theme, we have our theme generation process.

  • Avatar
    Raha Amirchermahini

    our theme generation process !!!

    what is it ?

    means I cant edited file from C:\inetpub\wwwroot\mysite\theme and save them in orginally place ?

    why ?

    there is not any way to resolve this problem ??

  • Avatar
    Pedro Monte

    By default only administrators have write access to C:\inetpub\wwwroot . Two options:

    1. Login with an administrator account, and elevate you editor.
    2. Set IIS to use a different directory for its root folder, on which your normal account has write/delete access.
    3. Change the permissions on C:\inetpub\wwwroot .

    Reference: http://serverfault.com/questions/152763/windows7-iis7-cant-turn-off-read-only-flag-for-inetpub-wwwroot-cant-edit-web

  • Avatar
    Raha Amirchermahini

    Thanks Dear Friend Pedro

    I did all that . like as give permission all file of my application pool in IIs but that wasnt effective 

    But really thanks for your help dear friend 

    with the best regard

    Raha

  • Avatar
    Raha Amirchermahini

    Hi Beatriz

    I add my logo finaly after a year I can find a little about orchard

    as you've tut above I add my logo and paste my logo.png to ocntent/images 

    add the code you tut here 

    now my text logo ( site name ) is disappear but logo.png is still not sjow in the logo place 

    have a time please take a look at :

    http://mehren.sitecloud.cytanium.com

    great thanks

    Best regards Beatriz

    Raha

  • Avatar
    Pedro Monte

    Raha Amirchermahini, It seems that is missing the path to your image/logo

    background:url(../content/images/YOURIMAGE) no-repeat;

Got a question?

If you can't find the answer to your question, you can contact us.
We are here and happy to help.

Powered by Zendesk