Advanced menu: how to use it in Bind Tuning themes

Info: Starting in version 1.5, Orchard now supports sub-navigation items by default.
This article applies only to Orchard versions until 1.4.

Orchard's "Advanced Menu" is a 3rd party module that allows the creation of custom, hierarchical menus in Orchard websites. Unlike base Orchard which only has one level for navigation, with this module you can easily create multi-level navigation, with several submenus.

Making our themes display Orchard's Advanced Menu, is now pretty simple. Here's how to:

It's assumed that the Advanced Menu module is already installed.
  1. In your Orchard website, go to DashBoard > Widgets
  2. If you already have the Advanced module applied, click on the widget "Styled Menu Widget"
  3. Remove all menu values as follows: 

    orx.advancedmenu.settings.jpg

  4. Click Save
  5. Now, go to your server's Orchard folders structure
  6. Locate folder \Modules\Szmyd.Orcharda.Modules.Menu\Styles
  7. Rename the following files (we do not want to use them):
    • superfish.css to unused.superfish.css
    • superfish-vertical.css to unused.superfish-vertical.css

You're done!

Samples

orx.advancedmenu.samples.gif

Have more questions? Submit a request

Comments

  • Avatar
    Pamela McCarty

    I am using this in the Adel theme with Side nav. For some reason. See attached screen shot.

    I set up as above. I changed the css file names - didn't work. put them back to the default - didn't work. Basically the 'flyouts' are not working. The nav is nested with everything showing.

    There may be a conflict with the new version of the 'Advanced Menu' (?)

    I cannot send a link to the site because it is behind a firewall.

  • Avatar
    Pamela McCarty

    I have figured out what is wrong. The class is wrong for the side nav code.

     

    Right now it shows this: <ul id="menu-47" class="menu menu-main menu menu-main>

    and Right now it shows this: <ul id="menu-54" class="menu menu-main menu menu-main>

    And it should be this: <ul id="menu-47" class="menu menu-main sf-menu sf-vertical sf-js-enabled sf-shadow"> &  <ul id="menu-54" class="menu menu-main sf-menu sf-vertical sf-js-enabled sf-shadow">

     

    This is not something I am able to fix (I am not in a develpoer environment)

    Can someone PLEASE contact me so this can be fixed.

  • Avatar
    Beatriz Oliveira

    Hi Pamela, the classes you mention are automatically generated by Orchard.

    Can you provide a link to your page so that we can validate directly?

    Thank you.

  • Avatar
    Pedro Costa

    Hi,

    Will you be providing compatibility with the new navigation in v1.5 or Orchard?

    Thanks,

  • Avatar
    Beatriz Oliveira

    Hi Pedro, yes we will provide compatibility with Orchard 1.5 new nav widget. I'm just not sure if it will be ready in time for our next fix release, which will rollout in the next days.

  • Avatar
    Pedro Costa

    Awesome, will I be able to regenerate existing purchases when this fixes come out?

  • Avatar
    Beatriz Oliveira

    Existing customers will have access to the new version.

    Probably conversion will be handled by request (we haven't decided yet).

  • Avatar
    Todd D. Martin

    The Advanced Menu module does not work with current versions of Orchard, at least not for me.  I installed a clean version of Orchard 1.6 via AzureWebSites, updated to 1.61 via patch, and then installed Advanced Menu.  Once Advanced Menu was enabled, it crashed the site.  Any suggestions?

  • Avatar
    Beatriz Oliveira

    Todd, since version 1.5 Orchard now includes a new default navigation, which already supports sub-navigation items, and therefore Advanced Menu is no longer necessary in these versions of Orchard.

    You should have no issues using default Orchard's nav :)

Got a question?

If you can't find the answer to your question, you can contact us.
We are here and happy to help.

Powered by Zendesk